bba — 2012-08-24T07:05:11-04:00 — #1
Hi, forgive my lack of knowledge.
I am pretty new to web designing, and know practically nothing about PHP, but have made one site successfully before which included PHP, so am making a second in the same manner. I have just begun installing the CMS Perch on the site but when I went to run the setup, I received the message:
"Perch requires PHP 5.2 or greater to install. You have: PHP 4.3.2"
I have done a search of the web, but not found any answers I understand. Is this something I can resolve myself? If so maybe a layman's terms explanation might help me. Alternatively should I contact the website's host, which I understand is a small company (I am redesigning the site for a client).
Any help is much appreciated, sorry if this is super simple...
system — 2012-08-24T07:44:11-04:00 — #2
There are different versions of php. Php 4.xxx is quite old now, but 4.3.2 is the version installed on that particular server.
You need to contact the people in charge of the hosting to ask them how to upgrade php to the latest version. Be careful doing this if you have other sites running from the same php installation on the same host though, because old sites may stop working if they were coded for php4 and you suddenly upgrade to php5.
cheesedude — 2012-08-24T10:15:04-04:00 — #3
I cannot imagine any credible web hosting company running a PHP version that old unless they were also running PHP 5.x. Yes, you will have to contact your web host. I would imagine they are running both PHP 4.x and PHP 5.x and require an entry in an htaccess file or some other configuration change to enable use of PHP 5.x. That's the way many hosts were doing it two or three years ago before they started dropping PHP 4 entirely.
ralphm — 2012-08-24T10:20:23-04:00 — #4
Yes, it should be straightforward to ask your host to upgrade to PHP 5.2 or higher. If they won't, move to a better one, because no self respecting host should be serving up PHP 4 now.
logic_earth — 2012-08-24T10:52:57-04:00 — #5
No self respecting host should be using anything lower then 5.3 what with everything below that no longer getting security updates.
thruska — 2012-08-25T12:14:20-04:00 — #6
The PHP developers would say, "No self-respecting host should be using anything lower than 5.4." I'm on the PHP dev mailing list (mostly lurking) just to keep an eye on them since I use PHP extensively. Their general attitude is to not support older versions at all but they do one previous version just because it takes time to upgrade software.
To answer the original question, you need to contact your host about upgrading to a relatively recent version of PHP - this is something only they can do. If they won't, then it will be time to find a different web hosting provider.